Error installing on ubuntu 14.04

30 posts
Error installing on ubuntu 14.04

rogerwagner
New MMEX User

Posts: 1
Joined: Sun Jun 15, 2014 10:52 am
Hi.

I want to install MMEX on my Ubuntu 14.04 and i do this steps:
sudo apt-get install python-software-properties
sudo apt-add-repository ppa:mmex-developers/mmex-stable
sudo apt-get update

And when i run this:
sudo apt-get install mmex

This error show:
 mmex : Depends: libwxgtk2.9-0-unofficial (>= 2.9.0) but is not installed

My system is updated and stable, and te libwxgtk is:
libwxgtk2.8-0:amd64                                   2.8.12.1+dfsg-2ubuntu2

Its really needed an upgrade of libwxgtk for Ubuntu 14.04? 
Re: Error installing on ubuntu 14.04

Nikolay
MMEX Developer

Posts: 2279
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
libwxgtk-2.8 is outdated for mmex.
Re: Error installing on ubuntu 14.04

argawarga
New MMEX User

Posts: 1
Joined: Wed Jun 25, 2014 11:40 am
More info that might shed light on it to somebody

I get same error trying to install 1.0.0.3 stable and unstable in Linux mint 17 (Ubuntu 14,04).
mmex : Depends: libwxgtk2.9-0-unofficial (>= 2.9.0) but is not installed

then trying to directly install libwxgtk2.9-0-unofficial in synaptic gives this
libwxgtk2.9-0-unofficial:
Depends: libtiff4 but it is not installable
Depends: libwxbase2.9-0-unofficial but it is not going to be installed

I did find a comment somewhere that Ubuntu 14.04 ships with libtiff5 not libtiff4 (I do see libtiff4-dev in the repository.)

So it seems it's this libtiff thing but I don't know enough to proceed from here. Any ideas?
Re: Error installing on ubuntu 14.04

koszuf
New MMEX User

Posts: 1
Joined: Tue Jul 01, 2014 4:29 am
Hi,
I tried to install libwxgtk2.9-0-unofficial (even if I have v.3), but I got:
libwxgtk2.9-0-unofficial : Depends: libtiff4 but it is not installable

Problem is, that I don't have libtiff4 in my repository (ubuntu 14.04) and I have libtiff5. 

How to solve that?
Re: Error installing on ubuntu 14.04

Nikolay
MMEX Developer

Posts: 2279
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
you don't need wx2.9 if 3.0 already installed.
wx 3.0.1 needed for mmex.

More details here

https://sourceforge.net/p/moneymanagere ... 9%20Linux/
Re: Error installing on ubuntu 14.04

cyrilc_fr
New MMEX User

Posts: 4
Joined: Thu Nov 03, 2011 12:44 pm
Hi Nikolay

Do you mean that we cannot install MMEX 1.0 on Ubuntu 14.04 without building it first?

Because, I installed wx 3.0.1 on my system, but MMEX still won't install, with the same error about libwxgtk2.9-0-unofficial :
Code: Select all
$ sudo apt-get install mmex
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 mmex : Dépend: libwxgtk2.9-0-unofficial (>= 2.9.0) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Code: Select all
$ dpkg -l | grep libwxgtk
ii  libwxgtk-media2.8-0:amd64         2.8.12.1+dfsg-2ubuntu2    amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ media library runtime)
ii  libwxgtk2.8-0:amd64               2.8.12.1+dfsg-2ubuntu2    amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  libwxgtk3.0-0:amd64               3.0.0-2                   amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  libwxgtk3.0-0-unofficial:amd64    3.0.1-1.trusty            amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  libwxgtk3.0-dev                   3.0.1-1.trusty            amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
Regards,
Cyril
Re: Error installing on ubuntu 14.04

Nikolay
MMEX Developer

Posts: 2279
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
Please try install deb package available here:
http://sourceforge.net/projects/moneyma ... 1.1.0-RC3/
Re: Error installing on ubuntu 14.04

cyrilc_fr
New MMEX User

Posts: 4
Joined: Thu Nov 03, 2011 12:44 pm
This worked, thanks a lot!
And sorry for not having tried the 1.1 RC before...

Anyway, I was stuck with MMEX 0.9 for quite a long time and I'm really happy to be allowed to see the new version!
It looks very, very nice, that's a great job!

Again, thanks!
Re: Error installing on ubuntu 14.04

enboig
New MMEX User

Posts: 1
Joined: Tue Jul 22, 2014 1:47 am
Using ubuntu 14.04 (trusty) I tried to install RC03 but it fails complaining I don't have libwxbase3.0-0-unofficial and libwxgtk3.0-0-unofficial

Code: Select all
# dpkg -i mmex_1.1.0-RC3_amd64.deb
S'està seleccionant el paquet mmex prèviament no seleccionat.
(S'està llegint la base de dades… hi ha 373889 fitxers i directoris instaŀlats actualment.)
Preparing to unpack mmex_1.1.0-RC3_amd64.deb ...
Unpacking mmex (1.1.0) ...
dpkg: problemes de dependències impedeixen la configuració de mmex:
 mmex depèn de libwxbase3.0-0-unofficial; tot i així:
  El paquet libwxbase3.0-0-unofficial no està instaŀlat.
 mmex depèn de libwxgtk3.0-0-unofficial; tot i així:
  El paquet libwxgtk3.0-0-unofficial no està instaŀlat.
dpkg: error processing package mmex (--install):
 problemes de dependències - es deixa sense configurar
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
S'han trobat errors en processar:
 mmex



Code: Select all
# dpkg -l | grep libwxgtk
ii  libwxgtk-media2.8-0:amd64                   2.8.12.1+dfsg-2ubuntu2
ii  libwxgtk2.8-0:amd64                         2.8.12.1+dfsg-2ubuntu2
ii  libwxgtk3.0-0:amd64                         3.0.0-2
ii  libwxgtk3.0-dev                             3.0.0-2
Re: Error installing on ubuntu 14.04

landsinger
New MMEX User

Posts: 1
Joined: Sun Aug 03, 2014 2:49 pm
I'm having the same exact problem. Attempting to install the release candiate as well as MMEX from the software center will not allow me to install.
Who is online

Users browsing this forum: No registered users and 1 guest

cron