Error installing on ubuntu 14.04

30 posts
Re: Error installing on ubuntu 14.04

THHH
New MMEX User

Posts: 4
Joined: Mon Aug 04, 2014 7:07 am
"Error: Dependency is not satisfiable: libwxbase3.0-0-unofficial"

I can't install :cry:
Re: Error installing on ubuntu 14.04
User avatar
GabrieleV
MMEX Developer

Posts: 259
Joined: Wed Apr 09, 2014 1:45 pm
Location: Italy
We are working on it.

I hope that we will find a solution in short time.
Re: Error installing on ubuntu 14.04

Nikolay
MMEX Developer

Posts: 2289
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
THHH wrote:"Error: Dependency is not satisfiable: libwxbase3.0-0-unofficial"

I can't install :cry:
Seems libwxbase3.0-0-unofficial should be installed before mmex.
http://codelite.org/LiteEditor/WxWidgets30Binaries
Re: Error installing on ubuntu 14.04

pastone
New MMEX User

Posts: 6
Joined: Sat Dec 08, 2012 6:19 pm
Hi Nicolay,

I use both the Windows and Linux versions of mmex from different machines or partitions, keeping the data synchronised via Wuala.

I have just succeeded in installing the new version, 1.1.0, replacing 0.9.something, of mmex on Linux Mint 16 KDE 32-bit (which is based on Ubuntu 2013.10). This involved first installing the wx packages depended on from the codelite repository mentioned earlier in this thread. I used the raring version.

However I find that in the Linux version most of the Report screens do not work. They simply reproduce (more or less) the Home screen, with its current-month section.

This does not happen with the new version of mmex on Windows 7, where all appears to be working as intended.

Is there perhaps some dependency in Linux which has not been declared, and thus does not prevent installation, but is actually needed to make all features work properly? Or is the difficulty probably due to some oddity in my Mint installation?

Anyway, congratulations on an excellent program. Teething troubles are not unusual when there is a major version upgrade.

Best wishes,
Peter Stone
Re: Error installing on ubuntu 14.04

Nikolay
MMEX Developer

Posts: 2289
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
i used mint 14 nadia.

working fine. but i don't use packages. mmex has een builded from source files.

We need expert help of expert to have mmex available on launchpad.
Re: Error installing on ubuntu 14.04

pastone
New MMEX User

Posts: 6
Joined: Sat Dec 08, 2012 6:19 pm
To clarify my previous post, my installation on Mint 16 was by means of the mmex 1.1.0 .deb designed for Ubuntu 2014.04. Perhaps the .deb assumed that a package contained as a default in Ubuntu would be available.
Re: Error installing on ubuntu 14.04

jdt37b
New MMEX User

Posts: 9
Joined: Tue Apr 10, 2012 6:45 am
Hello,
For information, same problem "libwxbase3.0-0-unofficial" with Ubuntu 12.04 LTS (Precise).
The correction is also provided for Precise ?
Thanks
Re: Error installing on ubuntu 14.04

pastone
New MMEX User

Posts: 6
Joined: Sat Dec 08, 2012 6:19 pm
With the codelite packages for ubuntu 14.04 installed, the .deb of mmex 1.1.0 installs and works correctly on kubuntu 14.04 and on mint 17.

I suspect that the problem with earlier versions of ubuntu etc may relate to recent changes in libc6. It seems possible that the mmex deb should declare a dependency on libc6 => 2.19.

Best wishes,
Peter Stone
Re: Error installing on ubuntu 14.04

THHH
New MMEX User

Posts: 4
Joined: Mon Aug 04, 2014 7:07 am
^ yes i already had libwx3.0-0 installed, but not the unofficial version that it's looking for. i think just redirect it to a more common version
Re: Error installing on ubuntu 14.04
User avatar
phira
Super MMEX User

Posts: 91
Joined: Sat Dec 03, 2011 1:53 am
Location: Tournai, Belgium
Same problem on my side for ubuntu 14.04
I verified and libwxbase3.0-0 was installed before trying to upgrade mmex ( libwxbase3.0-0-2 , to be more precise)
Finance administrator for a non profit association ( Plumes et Calames ASBL )
Who is online

Users browsing this forum: No registered users and 1 guest