From what I can tell, when you select this option you are forced to enter the days in the occurrence field. This sets the (x) days right, but it doesn't make it infinite and instead makes it have that number of occurrences.

For example, lets say I want something to happen every 28 days, then it shows up as next due as being 28 days and shows 28 occurrences left.

That seems like an issue or bug to me, because I there is no option to have it set to 28 days but infinite occurrences.