[1.5.2] no packages for Ubuntu 18.04 and 20.04

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

ssummers
New MMEX User
Posts: 7
Joined: Thu May 03, 2018 1:16 pm
Are you a spam bot?: No

[1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by ssummers »

I wanted to upgrade mmex today, but there are no packages for Ubuntu 18.04 and 20.04 available, but for the older 16.04. When I install mmex_1.5.2-1.xenial_amd64.deb on my Ubuntu 18.04 machine I get this error

Code: Select all

mmex: error while loading shared libraries: libwx_gtk2u_webview-3.0.so.0: cannot open shared object file: No such file or directory
After copying that file from another PC I get

Code: Select all

mmex: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by mmex)
dbolton
MVP MMEX User
Posts: 75
Joined: Fri Jan 03, 2020 3:24 pm
Are you a spam bot?: No

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by dbolton »

Who maintains the Ubuntu packages? Is there someone interested in releasing updated packages?
Nikolay
MMEX Developer
Posts: 1511
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by Nikolay »

FYI
https://travis-ci.org/github/moneymanag ... /773473367

Code: Select all

toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit
ssummers
New MMEX User
Posts: 7
Joined: Thu May 03, 2018 1:16 pm
Are you a spam bot?: No

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by ssummers »

I don't know if this note is important too
Hi! It seems there are still plenty of builds running. We're pushing back the shutdown date to June 15th. Please consider migrating to travis-ci.com.
Nikolay
MMEX Developer
Posts: 1511
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by Nikolay »

tosim
New MMEX User
Posts: 17
Joined: Mon Dec 29, 2008 9:44 pm

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by tosim »

Go to:https://sourceforge.net/p/moneymanagere ... 1bc309c363

Scroll down until you see link to bionic: that will work for Ubuntu18.04. I believe the "fossa" link will work
with Ubuntu 20.04.
ssummers
New MMEX User
Posts: 7
Joined: Thu May 03, 2018 1:16 pm
Are you a spam bot?: No

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by ssummers »

tosim wrote: Sun Jun 06, 2021 3:32 pm Go to:https://sourceforge.net/p/moneymanagere ... 1bc309c363

Scroll down until you see link to bionic: that will work for Ubuntu18.04. I believe the "fossa" link will work
with Ubuntu 20.04.
Thanks, but there is only version 1.5.1 for Ubuntu 18.04 available, which I already use.
PMaff
New MMEX User
Posts: 16
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by PMaff »

ssummers wrote: Fri Jun 04, 2021 8:37 pm I wanted to upgrade mmex today, but there are no packages for Ubuntu 18.04 and 20.04 available, but for the older 16.04. When I install mmex_1.5.2-1.xenial_amd64.deb on my Ubuntu 18.04 machine I get this error

Code: Select all

mmex: error while loading shared libraries: libwx_gtk2u_webview-3.0.so.0: cannot open shared object file: No such file or directory
After copying that file from another PC I get

Code: Select all

mmex: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by mmex)
I was able to compile the packages for 1.5.2 and 1.5.1 from the sources and create a deb-file for Ubuntu 18.04.
I was also able to compile and run 1.5.3-Beta.1 for Ubuntu 18.04, but I did not want to beta test.

1.5.2 had an error with "local::facet::_S_create_c_locale name not valid" but 1.5.1 is running ok even if there is a missing language dialog.
See:
viewtopic.php?p=22087#p22087

Did you try

Code: Select all

find /usr/ -name "libwx_gtk*_webview*" -ls
   400257    128 -rw-r--r--   1 root     root       130576 Mär 28  2018 /usr/lib/x86_64-linux-gnu/libwx_gtk3u_webview-3.0.so.0.4.0
   400262      0 lrwxrwxrwx   1 root     root           28 Mär 28  2018 /usr/lib/x86_64-linux-gnu/libwx_gtk3u_webview-3.0.so -> libwx_gtk3u_webview-3.0.so.0
   400259      0 lrwxrwxrwx   1 root     root           32 Mär 28  2018 /usr/lib/x86_64-linux-gnu/libwx_gtk3u_webview-3.0.so.0 -> libwx_gtk3u_webview-3.0.so.0.4.0

Code: Select all

dpkg -S /usr/lib/x86_64-linux-gnu/libwx_gtk3u_webview-3.0.so
libwxgtk-webview3.0-gtk3-dev: /usr/lib/x86_64-linux-gnu/libwx_gtk3u_webview-3.0.so
and then install libwxgtk-webview3.0-gtk3-dev in this case?
Nikolay
MMEX Developer
Posts: 1511
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by Nikolay »

local::facet::_S_create_c_locale name not valid

this issue has been fixed.
I recommend 1.5.3-beta.
PMaff
New MMEX User
Posts: 16
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: [1.5.2] no packages for Ubuntu 18.04 and 20.04

Post by PMaff »

Nikolay wrote: Sat Jun 12, 2021 7:54 pm local::facet::_S_create_c_locale name not valid

this issue has been fixed.
I recommend 1.5.3-beta.
I wanted to use a stable non beta version.
Is there any way to get the language selection dialog in 1.5.3-beta from e.g. mmex Options ?
Because then I would eagerly wait for 1.5.3 final. :D
Edit: the language dialog thing is solved.
Post Reply