Crostini and MMEX - can't install 1.3.3 - bakefile issue

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

Post Reply
New MMEX User
Posts: 2
Joined: Mon May 13, 2019 9:29 pm
Are you a spam bot?: No

Crostini and MMEX - can't install 1.3.3 - bakefile issue

Post by martinz »

Hi all

I've been using MMEX for several years., always with Linux. Never had any problems I couldn't resolve up to now.

But I thought I'd try Crostini ( ... etup-guide) on my Chromebook, and tried to install MMEX from source (v1.3.3)

The issue I get is as follows:- all the standard installation works up to the bit where I try to run (to run bakefiles to build makefiles? never used this before)

Code: Select all

$ ./
[1/16] generating gnu from ../../po/po.bkl
[2/16] generating msvc from ../../po/po.bkl
[bakefile_gen] waiting for remaining jobs to finish after error...
[bakefile_gen] error: bakefile exited with error (-11)
using automake from /usr/share/automake-1.15
file INSTALL exists, skipping
file config.guess exists, skipping
file config.sub exists, skipping
file install-sh exists, skipping
If I just ignore this, then the stuff in the "po" directory doesn't compile when I type make.

Interestingly it works fine when installing on a Mint box or a Kubuntu box; goes through all 16 "generating ..." and the make works beautifully.

Bit of background - Crostini is a container running Debian Stretch (by default). It seems that something isn't installed or is at the wrong version.

I have, btw, tried installing 1.3.3 via snap, but that doesn't work due to some issue with Crostini. I gather that's being worked on.

Suggestions welcome. Or any more information anyone needs...

(FWIW - I CAN install 1.4 but (a) that's still under development and (b) my mmb database doesn't open under 1.4. But that's a different problem...)
Post Reply