Unable to attach

Mac OS X 10.9 or higher.
nuno
New MMEX User
Posts: 6
Joined: Sat Jul 15, 2017 11:56 am
Are you a spam bot?: No

Unable to attach

Post by nuno »

After installing the latest version for mac (1.3.3) i'm not being able to attach files.
Any idea/suggestion?

bingalls
New MMEX User
Posts: 5
Joined: Sat Apr 08, 2017 3:49 pm
Are you a spam bot?: No

Re: Unable to attach

Post by bingalls »

Attachments worked for me, on a system I had to build from source, because I have a case sensitive file system.
When I tried copying the files to a newer mac, with a default filesystem, and the official binary, attachments failed.
I've tried to build from source again on this new box, to see if that solves the attachment problem, but instructions have changed.
Hope this helps...

User avatar
GabrieleV
MMEX Developer
Posts: 158
Joined: Wed Apr 09, 2014 7:45 pm
Are you a spam bot?: No
Location: Italy

Re: Unable to attach

Post by GabrieleV »

Do you have any error message? Is attachment folder set correctly in options?

Inviato dal mio Nexus 5X utilizzando Tapatalk

astern
New MMEX User
Posts: 5
Joined: Wed Aug 31, 2016 9:37 pm
Are you a spam bot?: No
Location: Austria

Re: Unable to attach

Post by astern »

Hi, same Issue, not only with Attachments but also with modifying accounts.

Version 1.3.3, attach file:
Bildschirmfoto 2017-08-29 um 16.41.57.jpg
Bildschirmfoto 2017-08-29 um 16.41.57.jpg (5.54 KiB) Viewed 8210 times
Version 1.3.3 modify icon for Account:
Bildschirmfoto 2017-08-29 um 16.47.20.jpg
Bildschirmfoto 2017-08-29 um 16.47.20.jpg (5.09 KiB) Viewed 8210 times
Version 1.3.1, attach file:
Bildschirmfoto 2017-08-29 um 16.40.37.jpg
Bildschirmfoto 2017-08-29 um 16.40.37.jpg (6.02 KiB) Viewed 8210 times
Version 1.3.1 modify icon for account:
Bildschirmfoto 2017-08-29 um 16.41.22.jpg
Bildschirmfoto 2017-08-29 um 16.41.22.jpg (5.39 KiB) Viewed 8210 times
Overview, V.1.3.1, upper part:
Bildschirmfoto 2017-08-29 um 16.47.20.jpg
Bildschirmfoto 2017-08-29 um 16.47.20.jpg (5.09 KiB) Viewed 8210 times
lower part: not published due to forum restrictions ... ;-((

So to describe the effect:
All Entries in the selectionbox are disabled - and dont get confused, as the inline Screenshots can appear in wrong order compared to preview:
16:39 & 16:40 show working Version 1.3.1, 16:41 show not working V. 1.3.3, whereas 16:47 shows upper part of attachment window
Attachments
Bildschirmfoto 2017-08-29 um 16.39.49.jpg
Bildschirmfoto 2017-08-29 um 16.39.49.jpg (5.54 KiB) Viewed 8210 times

astern
New MMEX User
Posts: 5
Joined: Wed Aug 31, 2016 9:37 pm
Are you a spam bot?: No
Location: Austria

Re: Unable to attach

Post by astern »

astern wrote:Hi, same Issue, not only with Attachments but also with modifying accounts.

Version 1.3.3, attach file:
1505: Bildschirmfoto 2017-08-29 um 16.41.22.jpg
Version 1.3.3 modify icon for Account:
1506: Bildschirmfoto 2017-08-29 um 16.41.57.jpg
Version 1.3.1, attach file:
1503: Bildschirmfoto 2017-08-29 um 16.39.49.jpg
Version 1.3.1 modify icon for account:
1504: Bildschirmfoto 2017-08-29 um 16.40.37.jpg
Overview, V.1.3.1, upper part:
1507: Bildschirmfoto 2017-08-29 um 16.47.20.jpg
lower part: not published due to forum restrictions ... ;-((

So to describe the effect:
All Entries in the selectionbox are disabled - and dont get confused, as the inline Screenshots can appear in wrong order compared to preview:
16:39 & 16:40 show working Version 1.3.1, 16:41 show not working V. 1.3.3, whereas 16:47 shows upper part of attachment window
but, guess what, macos-mmex-1.4.0-ALPHA-1 sees both selection boxes working again. wxWidgets 3.0.2 & 3.0.3 seem to work, 3.1.0 fails. Is there an easy way to adapt 1.3.3 to wxWidgets 3.0.something?
As I do not assume, that any code has been altered, I'd be very thankful for any hint...
kind regards

User avatar
GabrieleV
MMEX Developer
Posts: 158
Joined: Wed Apr 09, 2014 7:45 pm
Are you a spam bot?: No
Location: Italy

Re: Unable to attach

Post by GabrieleV »

Unfortunately I cannot test on Mac but I don't remember big changes in that function, so it could be a wxwidgets related issue

Inviato dal mio Nexus 5X utilizzando Tapatalk

astern
New MMEX User
Posts: 5
Joined: Wed Aug 31, 2016 9:37 pm
Are you a spam bot?: No
Location: Austria

Re: Unable to attach

Post by astern »

So, just trying to find out how to compile on OSX myself
- link https://github.com/moneymanagerex/money ... L.macOS.md  in forum  is not accessible - do you have any ideas why?

dahling
New MMEX User
Posts: 1
Joined: Tue Sep 05, 2017 5:39 pm
Are you a spam bot?: No

Re: Unable to attach

Post by dahling »

Exactly why I registered to say. I just downloaded it myself and it says:

<!--
/* Font Definitions */
@font-face
{font-family:"MS 明朝";
panose-1:0 0 0 0 0 0 0 0 0 0;
mso-font-charset:128;
mso-generic-font-family:roman;
mso-font-format:other;
mso-font-pitch:fixed;
mso-font-signature:1 134676480 16 0 131072 0;}
@font-face
{font-family:"MS 明朝";
panose-1:0 0 0 0 0 0 0 0 0 0;
mso-font-charset:128;
mso-generic-font-family:roman;
mso-font-format:other;
mso-font-pitch:fixed;
mso-font-signature:1 134676480 16 0 131072 0;}
@font-face
{font-family:Cambria;
panose-1:2 4 5 3 5 4 6 3 2 4;
mso-font-charset:0;
mso-generic-font-family:auto;
mso-font-pitch:variable;
mso-font-signature:-536870145 1073743103 0 0 415 0;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{mso-style-unhide:no;
mso-style-qformat:yes;
mso-style-parent:"";
margin:0cm;
margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:12.0pt;
font-family:Cambria;
mso-ascii-font-family:Cambria;
mso-ascii-theme-font:minor-latin;
mso-fareast-font-family:"MS 明朝";
mso-fareast-theme-font:minor-fareast;
mso-hansi-font-family:Cambria;
mso-hansi-theme-font:minor-latin;
mso-bidi-font-family:"Times New Roman";
mso-bidi-theme-font:minor-bidi;}
.MsoChpDefault
{mso-style-type:export-only;
mso-default-props:yes;
font-family:Cambria;
mso-ascii-font-family:Cambria;
mso-ascii-theme-font:minor-latin;
mso-fareast-font-family:"MS 明朝";
mso-fareast-theme-font:minor-fareast;
mso-hansi-font-family:Cambria;
mso-hansi-theme-font:minor-latin;
mso-bidi-font-family:"Times New Roman";
mso-bidi-theme-font:minor-bidi;}
@page WordSection1
{size:612.0pt 792.0pt;
margin:72.0pt 90.0pt 72.0pt 90.0pt;
mso-header-margin:36.0pt;
mso-footer-margin:36.0pt;
mso-paper-source:0;}
div.WordSection1
{page:WordSection1;}
-->
Attachment folder not defined.Please set it in Tools -> Options -> Attachments

So, there is a Tools in the toolbar, but I don't see an 'options' or 'attachments'....

Total boo hoo....as this would make it perfect for me.

If any replies for non-techy people, would be very gratified!

Thanks!

nuno
New MMEX User
Posts: 6
Joined: Sat Jul 15, 2017 11:56 am
Are you a spam bot?: No

Re: Unable to attach

Post by nuno »

I don' received any message of error.

If i open MMEX 1.3.3 and try to attach, just can't select the field
Captura de ecrã 2017-09-15, às 12.39.46.png
Captura de ecrã 2017-09-15, às 12.39.46.png (25.26 KiB) Viewed 8102 times
If i open MMEX 1.3.1 and try to attach, no problem 
Captura de ecrã 2017-09-15, às 12.40.45.png
Captura de ecrã 2017-09-15, às 12.40.45.png (26.08 KiB) Viewed 8102 times
Attachments
Captura de ecrã 2017-09-15, às 12.40.45.png
Captura de ecrã 2017-09-15, às 12.40.45.png (26.08 KiB) Viewed 8102 times

omalleypat
MMEX Developer
Posts: 112
Joined: Tue Jul 28, 2009 10:34 pm
Are you a spam bot?: No
Location: Atchison, KS

Re: Unable to attach

Post by omalleypat »

I issued a new build of v1.3.3 for mac with wxWidgets 3.0.2 - this solves the right-click menu greyed out issue. https://www.moneymanagerex.org/news/ite ... ild-v1-3-3

Post Reply