Problem with CSV imported transactions

General discussion on all other topics under the sun.

Moderator: Renato

Post Reply
john3voltas
New MMEX User
Posts: 9
Joined: Wed Nov 02, 2016 6:52 am
Are you a spam bot?: No

Problem with CSV imported transactions

Post by john3voltas »

Hi there. I am new to MMEX.
Just started using it yesterday.
When I edit a transaction to change the payee/category that shows a proper value in the Account View>view all transactions, for instance
Withdrawal 14,40, when the child window opens so that I can make my changes the Amount figure is automatically set to 1.440,00 instead
of the original 14,40.

I am using the portable stable version 1.2.7 for Windows 64 using the "English translation".
Being Portuguese, I had to change the currency to Euro/€ but I edited the decimal and grouping characters. After my changes, decimal is now set to coma (,) and grouping is set to period (.) which is the way we use it in our country (and perhaps all over Europe?).
Also I imported from CSV all my checking account transaction since 2011 with the fields Date, Don't care, Note, Notes, Withdrawal, Deposit, Balance, Don't care using the semi-colon (; ) as the CSV separator.
Everything was imported fine and I can see that the withdrawal/deposit/balance fields are all showing proper figures with the grouping and decimal characters just the way I set them up.
All help appreciated.
Cheers
Nikolay
MMEX Developer
Posts: 1400
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Problem with CSV imported transactions

Post by Nikolay »

john3voltas
New MMEX User
Posts: 9
Joined: Wed Nov 02, 2016 6:52 am
Are you a spam bot?: No

Re: Problem with CSV imported transactions

Post by john3voltas »

Hi Nikolay. Thanks for your reply.
That didn't work for me.
You will notice that in my original message I did change the decimal to coma (,) and the grouping to dot (.)
I also happened to try it without any grouping character (which looks foul :( ) and it still didn't work.
What works: choose the proper currency (Euro) and the choose the right grouping (.) and decimal (,) characters. Then close MMEX. Then reopen MMEX. Then import the CSV. Then edit a transaction. Perfect. :)
If I open MMEX and do all the settings and try to import without closing and reopening I get the issue. But if I close and reopen before importing it works flawlessly.
Remember, I'm using the portable package. Maybe it has influence?
Nikolay
MMEX Developer
Posts: 1400
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Problem with CSV imported transactions

Post by Nikolay »

It's annoining bugs. In future I'll add musk for amounts.
Post Reply