v.1.3.6 - Incorrect balance sometimes shown ...

Vista, 7, 8, 8.1. Unicode builds: x86, x64, ia64 versions available.

Moderator: Renato

paulcroft
Super MMEX User
Posts: 42
Joined: Fri Oct 29, 2010 9:48 pm
Are you a spam bot?: No
Location: London, England

Re: v.1.3.6 - Incorrect balance sometimes shown ...

Post by paulcroft »

Hi Nicolay

I think you're right. If the transactions are sorted by date of entry as well as by value this would lead to the anomaly we're seeing and there is no obvious reason for it, i.e. no obvious reason for sorting in the way that the programme does.

As I see it the balance should ONLY be based on the preceding entry, irrespective of the date of entry. For example, if the balance is £500 and the next transaction is a withdrawal of £50 the balance associated with this transaction, i.e. the balance on that row, must show as £450. If there are other transactions on that day, irrespective of their order, each balance must be accurate relative only to the preceding entry.

Using Excel I've set up a simple database with a few entries in the same format as in MMEX and the BALANCE cell has the simple formula:

"= preceding balance minus withdrawal or plus deposit"

If I select the whole table and sort on any column, up or down, the balance in any row is always accurate.
If I do the same with the test account the balance shown in any row is frequently inaccurate relative to that row.

If it would help us get to the bottom of this I am more than happy to send you a copy of the test account I set up and the simple spreadsheet I copied from it. On sorting the test account the balance associated with any entry is frequently wrong while the Excel spreadsheet's balance is always right.
Paul, MMEX user since April 2010
Nikolay
MMEX Developer
Posts: 1509
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: v.1.3.6 - Incorrect balance sometimes shown ...

Post by Nikolay »

paulcroft
Super MMEX User
Posts: 42
Joined: Fri Oct 29, 2010 9:48 pm
Are you a spam bot?: No
Location: London, England

Re: v.1.3.6 - Incorrect balance sometimes shown ...

Post by paulcroft »

Thanks for the link Nicolay, I shall follow this this there.
Paul, MMEX user since April 2010
paulcroft
Super MMEX User
Posts: 42
Joined: Fri Oct 29, 2010 9:48 pm
Are you a spam bot?: No
Location: London, England

Re: v.1.3.6 - Incorrect balance sometimes shown ...

Post by paulcroft »

... and I see that you've fixed it. Impressive. That's why we (I and the other 7,000 + users) love this programme and it's behind the scenes team.

Cheers for now,
Paul, MMEX user since April 2010
Post Reply