Issue on Big Sur - error with decimal values

Mac OS X 10.9 or higher.

Moderator: Renato

Post Reply
penguinvitamins2
New MMEX User
Posts: 3
Joined: Tue Dec 01, 2020 8:35 am
Are you a spam bot?: No

Issue on Big Sur - error with decimal values

Post by penguinvitamins2 »

Entries show have been imported via csv file. Trying to edit it, MMEX removes the cent value when opening the edit dialog
Entries show have been imported via csv file. Trying to edit it, MMEX removes the cent value when opening the edit dialog
Screenshot 2020-12-07 at 10.48.27.png (60.47 KiB) Viewed 696 times
Error shown when trying to resave the record.
Error shown when trying to resave the record.
Screenshot 2020-12-07 at 10.48.51.png (83.58 KiB) Viewed 696 times
Hi Support

Having trouble with MMEX 1.3.5 after upgrading to Big Sur (11.0.0 and 11.0.1).
Thanks for assistance in advance.

Since upgrading to Big Sur, the decimal values is displayed as Rxxx,xxx,.yy vs Rxxx,xxx.yy (example R105,020,.05 vs the correct R105,020.05 - Note the group symbol after the last value before the decimal symbol)

1. Editing an existing record gives the error, Invalid format... (see screenshot)
2. Tried a new blank database. Cannot enter a starting value, gives same error as when you want to edit an existing record
3. Creating a new record after leaving the new account with a zero starting value gives the same error, invalid format...
4. Tried to change the currency grouping symbol from "," to " ". Gives the same error, invalid format, then program crash
5. De-installed, reinstalled MMEX latest version (downloaded a fresh copy). Same error when creating a new database.
6. Changed currency. Same error, invalid format...
7. Changed regional settings of the MacBook. No luck either
8. Browsing the database with SQL Lite Browser, the record currency values are displayed correctly as e.g. R105,020.05. All table Records can be edited successfully via the SQL Lite browser, and after opening MMEX these changes shows but with the incorrect format as above. It also still cannot be changed without getting the Invalid format error.

My setup is:
Version 1.3.5 latest installed
Original Database runs on a MacBook Pro 2018 and was 100% working prior Big Sur.
I've also installed a new copy of MMEX on a Macbook Air M1 2020 and created a new database. Exact same issue.


Example database attached. Opening the databases used on the MAC, works 100% on a Windows PC. (Unfortunately I don't own it)
Attachments
test.mmb
(256 KiB) Downloaded 62 times
penguinvitamins2
New MMEX User
Posts: 3
Joined: Tue Dec 01, 2020 8:35 am
Are you a spam bot?: No

Re: Issue on Big Sur - error with decimal values

Post by penguinvitamins2 »

Solved above by changing my MacBook's regional settings from non US to US (gave error while the PC's regional settings was set to South African, tried a few other regions and gave me the same errors). This is a kind of a problem as some programs are regional sensitive. At least while my MacBook is now set to US Language/Region I can change the date, time and currency type from the US region to my own country's (ZAR). Note While my MacBook regional settings is set to South Africa, I've also tried to explicitly set the mmex app to US language under the regional settings of the MacBook, but it did not work.(Big Sur, Under System Settings, Language and Region, select "Apps", Add mmex and select language)
Nikolay
MMEX Developer
Posts: 1511
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Issue on Big Sur - error with decimal values

Post by Nikolay »

Post Reply