Upgraded to 1.3.5 - Lost database - HELP!!!

Mac OS X 10.9 or higher.

Moderator: Renato

Post Reply
ehexlee
New MMEX User
Posts: 6
Joined: Sun Aug 09, 2020 6:56 pm
Are you a spam bot?: No

Upgraded to 1.3.5 - Lost database - HELP!!!

Post by ehexlee »

Sorry if this is a double-post. Original post for this topic was approved by moderator, but no longer shows up on the board (The requested topic does not exist.).

Running MMEX 1.3.5 from 1.3.4 on OS X 10.13.6

I upgraded to 1.3.5. I did not make a manual backup of the database.

Initially, when I upgraded, it asked if I wanted to delete the old version (1.3.4) to which I said yes.

After install when I tried to run, it said 1.3.5 was damaged and needed to be moved to the trash. I ran the terminal fix for quarantine and it then ran fine.

BUT, now I cannot find my database. I tried looking in the ~/library/application support but did not find an entry for MMEX there. I tried searching for .mmb files, but the only one I found was a very old manual backup.

I'm hoping there is a way to get the database back. I would hate to have lost a year of financials.

Thanks!
Nikolay
MMEX Developer
Posts: 1511
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by Nikolay »

ehexlee
New MMEX User
Posts: 6
Joined: Sun Aug 09, 2020 6:56 pm
Are you a spam bot?: No

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by ehexlee »

Thanks for the link. I did the quarantine fix in terminal (as stated in my OP). I can start the program fine. But my problem is I can't connect to the database for my financials.

Since my original post, I was able to find the "mmexini.db3" file (~/Users/aroneo/Library/Application Support/MoneyManagerEx/mmexini.db3) by using the "Go" menu in Finder, holding option and selecting Library.

I don't know how to reconnect MMEX with that database.

MMEX can't see that directory since it's hidden, so I can't open a database at the above location from within the program. Additionally, it doesn't seem to know how to open a .db3 file. I copied the "mmexini.db3" out of my library into my documents folder. MMEX can see the file there, but it doesn't recognize it as a valid selectable file -- it's grayed out.

Not sure how to get MMEX to reconnect with my database.

Ideas?
User avatar
Renato
MVP MMEX User
Posts: 329
Joined: Mon Apr 25, 2011 7:36 pm
Are you a spam bot?: No
Location: near Zurich
Contact:

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by Renato »

regards Renato use MMEX since 2009, now with Windows 11
ehexlee
New MMEX User
Posts: 6
Joined: Sun Aug 09, 2020 6:56 pm
Are you a spam bot?: No

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by ehexlee »

Thanks for the continued help. I went to that thread and I'm trying to find my .mmb file using the info there.

From the thread:
Nikolay wrote: Sun Jun 14, 2020 1:30 pm The file should be In ~/.mmex
I turned hidden files/folders to visible (command + shift + ".")

Does this mean there should be a hidden folder ".mmex" under the my username root directory?

And *should* that folder have the .mmb file in there?

I don't see the ".mmex" folder under my username root. I do see a "mmex" and "MoneyManagerEx" folders in "~/Library/Application Support/". But no .mmb file. Just the .db3 file in each.

I've done a search of the my hard drive for .mmb and even turned on the switch to look for invisible. Only thing it finds is a very old manual backup. Not my current .mmb file.

I assume the needed .mmb file has to be *somewhere* but I just can't find it.
User avatar
Renato
MVP MMEX User
Posts: 329
Joined: Mon Apr 25, 2011 7:36 pm
Are you a spam bot?: No
Location: near Zurich
Contact:

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by Renato »

it's an encrypted MMB files (*.emb) ??
regards Renato use MMEX since 2009, now with Windows 11
ehexlee
New MMEX User
Posts: 6
Joined: Sun Aug 09, 2020 6:56 pm
Are you a spam bot?: No

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by ehexlee »

What is an encrypted .mmb file? The .db3 file. A hidden .mmb file. Not sure what you're referring to exactly.

I tried a search for ".emb" or "*.emb" and didn't get any results.

I am using 10.13.6 and the search function in the finder. I am attempting to search from the root directory. Is it possible I am using the search parameter incorrectly?

Really hoping that database is hiding on this mac somewhere.

:fingerscrossed.emoji:
User avatar
Renato
MVP MMEX User
Posts: 329
Joined: Mon Apr 25, 2011 7:36 pm
Are you a spam bot?: No
Location: near Zurich
Contact:

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by Renato »

if there is no .mmb or .emb file, then there is no data for MMEX

In such a case only downloading the data from a backup helps. If you did not make a backup, which unfortunately happens very often, then probably nobody can help (conjure).

MMEX creates backups for every session by itself unless you turn off this option.
Because also these automatically created files (xxxxxx.mmb_update_YYYY-MM-DD.mmb) are missing, good advice is expensive.
regards Renato use MMEX since 2009, now with Windows 11
ehexlee
New MMEX User
Posts: 6
Joined: Sun Aug 09, 2020 6:56 pm
Are you a spam bot?: No

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by ehexlee »

Thought all was lost.

Ended up doing a system security update and a restart. And now the .mmb file (and backup) is there!

Why? Who knows. But I'm not complaining. I will start doing periodic offsite backup just in case.

Thanks for the help!
User avatar
Renato
MVP MMEX User
Posts: 329
Joined: Mon Apr 25, 2011 7:36 pm
Are you a spam bot?: No
Location: near Zurich
Contact:

Re: Upgraded to 1.3.5 - Lost database - HELP!!!

Post by Renato »

You're welcome. Thanks for the feedback.
regards Renato use MMEX since 2009, now with Windows 11
Post Reply