MMEX on Mint 20.2

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

Post Reply
micoud
New MMEX User
Posts: 2
Joined: Mon Sep 13, 2021 8:36 am
Are you a spam bot?: No

MMEX on Mint 20.2

Post by micoud »

Hello,
I want to install mmex. The installation proceeds normally, an icon is placed in the "office automation" tab but I cannot run mmex.
If I type in console the command mmex, I get the following error message:

Code: Select all

 mmex: error while loading shared libraries: libwx_gtk2u_core-3.0.so.0: cannot open shared object file: No such file or directory Not sure what I'm doing wrong.
thanks for your advices.


My PC:
AMD 5.3600 / MEM 32GB
NVIDIA GeForce GTX 1060 3GB
Mint 20.2
XFCE4

Edit 14/09
found on the source site forge:
berninghausen Posted 2021-09-02
Downloaded the .deb install file. Installed it, found it in the linuxmint menu. Won't load. Entering 'mmex' in a terminal window gets me the message: mmex: error while loading shared libraries: libwx_gtk2u_core-3.0.so.0: cannot open shared object file: No such file or directory Not sure what I'm doing wrong. Is LinuxMint the wrong distro for MMEX? Any ideas?
PMaff
Super MMEX User
Posts: 23
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: MMEX on Mint 20.2

Post by PMaff »

On my SuSE machine this one is installed:
"libwx_gtk2u_core-suse3 - wxWidgets Library
Library for the wxWidgets cross-platform GUI."

I do not know if there is an equivalent on Mint and if it is named a bit different.

ldd in my case gives:

> ldd /usr/bin/mmex
linux-vdso.so.1 (0x00007ffeacfb4000)
libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007f3c26525000)
libwx_gtk3u_core-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_core-3.1.so.5 (0x00007f3c25af8000)
libwx_gtk3u_qa-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_qa-3.1.so.5 (0x00007f3c258c9000)
libwx_gtk3u_html-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_html-3.1.so.5 (0x00007f3c255f1000)
libwx_baseu_xml-3.1.so.5 => /usr/local/lib64/libwx_baseu_xml-3.1.so.5 (0x00007f3c253df000)
libwx_gtk3u_aui-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_aui-3.1.so.5 (0x00007f3c2513f000)
libwx_gtk3u_stc-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_stc-3.1.so.5 (0x00007f3c24c83000)
libwx_gtk3u_webview-3.1.so.5 => /usr/local/lib64/libwx_gtk3u_webview-3.1.so.5 (0x00007f3c24a57000)
...

so these libraries should be at the place, where mmex is looking for them.
When you installed mmex did it announce some missing dependencies?
micoud
New MMEX User
Posts: 2
Joined: Mon Sep 13, 2021 8:36 am
Are you a spam bot?: No

Re: MMEX on Mint 20.2

Post by micoud »

thank you for your reply

"When you installed mmex did it announce some missing dependencies?"

No, everything is going well, and I have the Money Manager icon in the 'office' tab, but nothing happens when I click on it.
And when I enter the command 'mmex' in console, I get the message below:

admoi@rbs455vb:~/Bureau$ mmex
mmex: error while loading shared libraries: libwx_gtk2u_core-3.0.so.0: cannot open shared object file: No such file or directory



admoi@rbs455vb:~/Bureau$ ldd /usr/bin/mmex
/usr/bin/mmex: /lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /usr/bin/mmex)
linux-vdso.so.1 (0x00007ffcf2645000)
libcurl.so.4 => /lib/x86_64-linux-gnu/libcurl.so.4 (0x00007ff5e6bf9000)
libwx_gtk2u_core-3.0.so.0 => not found
libwx_gtk2u_qa-3.0.so.0 => not found
libwx_gtk2u_html-3.0.so.0 => not found
libwx_baseu_xml-3.0.so.0 => not found
libwx_gtk2u_aui-3.0.so.0 => not found
libwx_gtk2u_adv-3.0.so.0 => not found
libwx_gtk2u_stc-3.0.so.0 => not found
libwx_gtk2u_webview-3.0.so.0 => not found
libwx_baseu-3.0.so.0 => not found
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ff5e6bf1000)
liblua5.3.so.0 => not found
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff5e6a0e000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff5e68bf000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff5e68a4000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff5e6881000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff5e668f000)
libnghttp2.so.14 => /lib/x86_64-linux-gnu/libnghttp2.so.14 (0x00007ff5e6664000)
libidn2.so.0 => /lib/x86_64-linux-gnu/libidn2.so.0 (0x00007ff5e6643000)
librtmp.so.1 => /lib/x86_64-linux-gnu/librtmp.so.1 (0x00007ff5e6623000)
libssh.so.4 => /lib/x86_64-linux-gnu/libssh.so.4 (0x00007ff5e65b5000)
libpsl.so.5 => /lib/x86_64-linux-gnu/libpsl.so.5 (0x00007ff5e65a2000)
libssl.so.1.1 => /lib/x86_64-linux-gnu/libssl.so.1.1 (0x00007ff5e650f000)
libcrypto.so.1.1 => /lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007ff5e6237000)
libgssapi_krb5.so.2 => /lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007ff5e61ea000)
libldap_r-2.4.so.2 => /lib/x86_64-linux-gnu/libldap_r-2.4.so.2 (0x00007ff5e6194000)
liblber-2.4.so.2 => /lib/x86_64-linux-gnu/liblber-2.4.so.2 (0x00007ff5e6183000)
libbrotlidec.so.1 => /lib/x86_64-linux-gnu/libbrotlidec.so.1 (0x00007ff5e6175000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007ff5e6159000)
/lib64/ld-linux-x86-64.so.2 (0x00007ff5e6ca0000)
libunistring.so.2 => /lib/x86_64-linux-gnu/libunistring.so.2 (0x00007ff5e5fd5000)
libgnutls.so.30 => /lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007ff5e5dff000)
libhogweed.so.5 => /lib/x86_64-linux-gnu/libhogweed.so.5 (0x00007ff5e5dc8000)
libnettle.so.7 => /lib/x86_64-linux-gnu/libnettle.so.7 (0x00007ff5e5d8e000)
libgmp.so.10 => /lib/x86_64-linux-gnu/libgmp.so.10 (0x00007ff5e5d0a000)
libkrb5.so.3 => /lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007ff5e5c2b000)
libk5crypto.so.3 => /lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007ff5e5bfa000)
libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007ff5e5bf3000)
libkrb5support.so.0 => /lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007ff5e5be4000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007ff5e5bc8000)
libsasl2.so.2 => /lib/x86_64-linux-gnu/libsasl2.so.2 (0x00007ff5e5bab000)
libgssapi.so.3 => /lib/x86_64-linux-gnu/libgssapi.so.3 (0x00007ff5e5b64000)
libbrotlicommon.so.1 => /lib/x86_64-linux-gnu/libbrotlicommon.so.1 (0x00007ff5e5b41000)
libp11-kit.so.0 => /lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007ff5e5a0b000)
libtasn1.so.6 => /lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007ff5e59f5000)
libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007ff5e59ee000)
libheimntlm.so.0 => /lib/x86_64-linux-gnu/libheimntlm.so.0 (0x00007ff5e59e0000)
libkrb5.so.26 => /lib/x86_64-linux-gnu/libkrb5.so.26 (0x00007ff5e594d000)
libasn1.so.8 => /lib/x86_64-linux-gnu/libasn1.so.8 (0x00007ff5e58a6000)
libhcrypto.so.4 => /lib/x86_64-linux-gnu/libhcrypto.so.4 (0x00007ff5e586e000)
libroken.so.18 => /lib/x86_64-linux-gnu/libroken.so.18 (0x00007ff5e5855000)
libffi.so.7 => /lib/x86_64-linux-gnu/libffi.so.7 (0x00007ff5e5849000)
libwind.so.0 => /lib/x86_64-linux-gnu/libwind.so.0 (0x00007ff5e581d000)
libheimbase.so.1 => /lib/x86_64-linux-gnu/libheimbase.so.1 (0x00007ff5e580b000)
libhx509.so.5 => /lib/x86_64-linux-gnu/libhx509.so.5 (0x00007ff5e57bd000)
libsqlite3.so.0 => /lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007ff5e5694000)
libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007ff5e5659000)
admoi@rbs455vb:~/Bureau$
Post Reply