Solved-No language dialog for MMEX 1.5.1 on Ubuntu 18.04

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

Post Reply
PMaff
New MMEX User
Posts: 16
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Solved-No language dialog for MMEX 1.5.1 on Ubuntu 18.04

Post by PMaff »

I've been using mmex 1.3.3 on Ubuntu 18.04 as a snap now for a while and it is working fine.
Tried to compile 1.5.2 from scratch today and create the .deb package. This worked fine, but when starting the 1.5.2 version I get an error "local::facet::_S_create_c_locale name not valid".
And my current database is not opened afterwards.

So I tried 1.5.1 afterwards.
Creation of the deb package works.
But when starting 1.5.1 there is no language selection dialog and only English as language.
I removed $HOME/.mmex and I tried again: no language selection dialog.

Is that a known bug in 1.5.1 on Ubuntu 18.04 ?
Did not find anything about this.

Is there any way to select another language from the menus in mmex?
Edit: did not find any button to set this to solved.
Last edited by PMaff on Sun Jun 13, 2021 11:57 am, edited 1 time in total.
MartinArmstrong
Super MMEX User
Posts: 41
Joined: Tue Mar 02, 2021 10:24 am
Are you a spam bot?: No

Re: No language dialog for MMEX 1.5.1 on Ubuntu 18.04

Post by MartinArmstrong »

In 1.5.1 and 1.5.2, MMEX application language can be changed from the menu:

View | Switch Application Language

In 1.5.3 (not yet released) the language can also be changed from the Options dialog.
PMaff
New MMEX User
Posts: 16
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: No language dialog for MMEX 1.5.1 on Ubuntu 18.04

Post by PMaff »

MartinArmstrong wrote: Sun Jun 13, 2021 8:34 am In 1.5.1 and 1.5.2, MMEX application language can be changed from the menu:

View | Switch Application Language

In 1.5.3 (not yet released) the language can also be changed from the Options dialog.
Thx.
Post Reply