MMEX Desktop v1.3.4.rc.2 is ready https://sourceforge.net/projects/moneym ... 1.3.4-rc.2

Error installing on ubuntu 14.04

Almost any Unix workstation with GTK+ 2.0 and above.
THHH
New MMEX User
Posts: 2
Joined: Mon Aug 04, 2014 1:07 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by THHH »

"Error: Dependency is not satisfiable: libwxbase3.0-0-unofficial"

I can't install :cry:

User avatar
GabrieleV
MMEX Developer
Posts: 158
Joined: Wed Apr 09, 2014 7:45 pm
Are you a spam bot?: No
Location: Italy

Re: Error installing on ubuntu 14.04

Post by GabrieleV »

We are working on it.

I hope that we will find a solution in short time.

Nikolay
MMEX Developer
Posts: 1173
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Error installing on ubuntu 14.04

Post by Nikolay »

THHH wrote:"Error: Dependency is not satisfiable: libwxbase3.0-0-unofficial"

I can't install :cry:
Seems libwxbase3.0-0-unofficial should be installed before mmex.
http://codelite.org/LiteEditor/WxWidgets30Binaries

pastone
New MMEX User
Posts: 3
Joined: Sun Dec 09, 2012 12:19 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by pastone »

Hi Nicolay,

I use both the Windows and Linux versions of mmex from different machines or partitions, keeping the data synchronised via Wuala.

I have just succeeded in installing the new version, 1.1.0, replacing 0.9.something, of mmex on Linux Mint 16 KDE 32-bit (which is based on Ubuntu 2013.10). This involved first installing the wx packages depended on from the codelite repository mentioned earlier in this thread. I used the raring version.

However I find that in the Linux version most of the Report screens do not work. They simply reproduce (more or less) the Home screen, with its current-month section.

This does not happen with the new version of mmex on Windows 7, where all appears to be working as intended.

Is there perhaps some dependency in Linux which has not been declared, and thus does not prevent installation, but is actually needed to make all features work properly? Or is the difficulty probably due to some oddity in my Mint installation?

Anyway, congratulations on an excellent program. Teething troubles are not unusual when there is a major version upgrade.

Best wishes,
Peter Stone

Nikolay
MMEX Developer
Posts: 1173
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Error installing on ubuntu 14.04

Post by Nikolay »

i used mint 14 nadia.

working fine. but i don't use packages. mmex has een builded from source files.

We need expert help of expert to have mmex available on launchpad.

pastone
New MMEX User
Posts: 3
Joined: Sun Dec 09, 2012 12:19 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by pastone »

To clarify my previous post, my installation on Mint 16 was by means of the mmex 1.1.0 .deb designed for Ubuntu 2014.04. Perhaps the .deb assumed that a package contained as a default in Ubuntu would be available.

jdt37b
New MMEX User
Posts: 1
Joined: Tue Apr 10, 2012 12:45 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by jdt37b »

Hello,
For information, same problem "libwxbase3.0-0-unofficial" with Ubuntu 12.04 LTS (Precise).
The correction is also provided for Precise ?
Thanks

pastone
New MMEX User
Posts: 3
Joined: Sun Dec 09, 2012 12:19 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by pastone »

With the codelite packages for ubuntu 14.04 installed, the .deb of mmex 1.1.0 installs and works correctly on kubuntu 14.04 and on mint 17.

I suspect that the problem with earlier versions of ubuntu etc may relate to recent changes in libc6. It seems possible that the mmex deb should declare a dependency on libc6 => 2.19.

Best wishes,
Peter Stone

THHH
New MMEX User
Posts: 2
Joined: Mon Aug 04, 2014 1:07 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by THHH »

^ yes i already had libwx3.0-0 installed, but not the unofficial version that it's looking for. i think just redirect it to a more common version

User avatar
phira
Super MMEX User
Posts: 56
Joined: Sat Dec 03, 2011 7:53 am
Are you a spam bot?: No
Location: Tournai, Belgium
Contact:

Re: Error installing on ubuntu 14.04

Post by phira »

Same problem on my side for ubuntu 14.04
I verified and libwxbase3.0-0 was installed before trying to upgrade mmex ( libwxbase3.0-0-2 , to be more precise)
Finance administrator for a non profit association ( Plumes et Calames ASBL )

Post Reply