MMEX Desktop v1.3.4.rc.2 is ready https://sourceforge.net/projects/moneym ... 1.3.4-rc.2

Error installing on ubuntu 14.04

Almost any Unix workstation with GTK+ 2.0 and above.
User avatar
GabrieleV
MMEX Developer
Posts: 158
Joined: Wed Apr 09, 2014 7:45 pm
Are you a spam bot?: No
Location: Italy

Re: Error installing on ubuntu 14.04

Post by GabrieleV »

Hi,
menawhile I create new package with stable wx you can solve the problem with this:

Code: Select all

sudo apt-add-repository 'deb http://repos.codelite.org/wx3.0.1/ubuntu/ trusty universe'
sudo apt-get install curl
curl http://repos.codelite.org/CodeLite.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install libwxbase3.0-0-unofficial

sergiosos77
New MMEX User
Posts: 3
Joined: Mon Sep 15, 2014 1:49 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by sergiosos77 »

Any update on this issue? I too cannot install the version in Ubuntu 14.04

hmd
New MMEX User
Posts: 1
Joined: Fri Oct 10, 2014 8:37 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by hmd »

Sorry guys, but I'm having the same problem installing on elementary OS. Even after installing libwxbase3.0-0-unofficial in synaptic.
Could some please describe the whole process? When should I run the script?

robsonhcosta
New MMEX User
Posts: 1
Joined: Thu Jul 23, 2015 6:45 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by robsonhcosta »

Also could not install on ubuntu 14.04, the same error "This error show:
  MMEX: Depends:. libwxgtk2.9-0-unofficial (> = 2.9.0) but is not installed "very good application and I wonder if someone already managed to solve this problem Grateful..

sergiosos77
New MMEX User
Posts: 3
Joined: Mon Sep 15, 2014 1:49 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by sergiosos77 »

Hi, I just had to reinstall Ubuntu and it's the same problem again. 

Please guys, fix this issue that is causing problems to install MMEX on Ubuntu (in my case Ubuntu 14.04 64bits)
It's been a year since you promised to look into it.

Nikolay
MMEX Developer
Posts: 1173
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Error installing on ubuntu 14.04

Post by Nikolay »

Please ask help fron Ubuntu connunity.
We have no resources to help here.

Thos article shoul help to build mmec from scratch https://sourceforge.net/p/moneymanagere ... 9%20Linux/

norbertt
New MMEX User
Posts: 2
Joined: Sun Dec 20, 2015 9:49 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by norbertt »

GabrieleV wrote:Hi,
menawhile I create new package with stable wx you can solve the problem with this:

Code: Select all

sudo apt-add-repository 'deb http://repos.codelite.org/wx3.0.1/ubuntu/ trusty universe'
sudo apt-get install curl
curl http://repos.codelite.org/CodeLite.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install libwxbase3.0-0-unofficial
The codelite.org is offline. any other way?

norbertt
New MMEX User
Posts: 2
Joined: Sun Dec 20, 2015 9:49 am
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by norbertt »

I did this way:

sudo apt-get install python-software-properties
sudo apt-add-repository ppa:dwrj87/mmex-test
sudo apt-get update && sudo apt-get install mmex


But i got errors:
Can't find language files (.mo) at "/usr/local/share/mmex/po/en"
../src/generic/imaglist.cpp(66): assert "(bitmap.GetWidth() >= m_width && bitmap.GetHeight() == m_height) || (m_width == 0 && m_height == 0)" failed in Add(): invalid bitmap size in wxImageList: this might work on this platform but definitely won't under Windows.


ASSERT INFO:
../src/generic/imaglist.cpp(66): assert "(bitmap.GetWidth() >= m_width && bitmap.GetHeight() == m_height) || (m_width == 0 && m_height == 0)" failed in Add(): invalid bitmap size in wxImageList: this might work on this platform but definitely won't under Windows.
BACKTRACE:
[1] wxGenericImageList::Add(wxBitmap const&)
[2] navtree_images_list()
[3] mmGUIFrame::createControls()
[4] mmGUIFrame::mmGUIFrame(mmGUIApp*, wxString const&, wxPoint const&, wxSize const&)
[5] OnInitImpl(mmGUIApp*)
[6] mmGUIApp::OnInit()
[7] wxEntry(int&, wchar_t**)
[8] main
[9] __libc_start_main
[10] _start

Nikolay
MMEX Developer
Posts: 1173
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Error installing on ubuntu 14.04

Post by Nikolay »

it may be becouse some XPM images has not 16x16 resolution.

javiermarcon
New MMEX User
Posts: 4
Joined: Fri Mar 31, 2017 5:35 pm
Are you a spam bot?: No

Re: Error installing on ubuntu 14.04

Post by javiermarcon »

To solve the error "Can't find language files (.mo) at "/usr/local/share/mmex/po/en" you should make a folder called en in /usr/local/share/mmex/po/ and copy or symlink the .mo files in that folder. For example if you wandt spanish and english languages, run:

Code: Select all

sudo mkdir /usr/local/share/mmex/po/en
sudo ln -s /usr/local/share/mmex/po/spanish.mo /usr/local/share/mmex/po/en/spanish.mo
sudo ln -s /usr/local/share/mmex/po/english.mo /usr/local/share/mmex/po/en/english.mo 
After doing that, you should restart mmex and the language chooser dialog will appear to select the desired language.

Post Reply