Finally a PPA for Ubuntu!

12 posts
Finally a PPA for Ubuntu!
User avatar
bobzr
New MMEX User

Posts: 2
Joined: Sun Jul 05, 2015 2:42 pm
Thanks so much to the devs who made available this ppa for ubuntu:
https://launchpad.net/~dwrj87/+archive/ubuntu/mmex-test

I was stuck with version 1.1.0 and now I finally have 1.2.4 on Ubuntu 15.10.
Thank you
:P
Re: Finally a PPA for Ubuntu!

Nikolay
MMEX Developer

Posts: 2284
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
Great! Many thanks to David Jones.
Re: Finally a PPA for Ubuntu!

naskoistaken
New MMEX User

Posts: 11
Joined: Wed Aug 19, 2015 4:02 am
Apparently version 1.2.5 hasn't made it to this PPA.

I don't insist on having the latest version by all means, but unfortunately the application shows a pop-up each time I start it, notifying me that there's a new version - 1.2.5 and even opens the MMEX homepage when I click FINISH.

It would be better if either 1) the application didn't notify me on each app start, or 2) the PPA was updated so that I had the means to upgrade to 1.2.5
Re: Finally a PPA for Ubuntu!

jackkerouac
New MMEX User

Posts: 1
Joined: Thu Feb 18, 2016 7:47 am
Agreed. It would be nice if the software didn't remind me every time there is an update I cannot get, except to build from scratch. Maybe every second time? :)
Re: Finally a PPA for Ubuntu!
User avatar
GabrieleV
MMEX Developer

Posts: 266
Joined: Wed Apr 09, 2014 1:45 pm
Location: Italy
I've reverted latest version for Unix to 1.2.4

Anyway in options it's possible to disable automatic update check at startup.

Inviato dal mio Nexus 5
Re: Finally a PPA for Ubuntu!

naskoistaken
New MMEX User

Posts: 11
Joined: Wed Aug 19, 2015 4:02 am
Thank you GabrieleV!
Re: Finally a PPA for Ubuntu!

vinu
New MMEX User

Posts: 1
Joined: Mon Mar 07, 2016 10:15 am
Thanks for providing the ppa. I am trying to install from Ubuntu 15.10 and the above repository is only available for 15.04 and 14.04. When I force my apt to fetch from Vivid (trying my luck :)) and install mmex, I am getting the following error:

The following packages have unmet dependencies:
 mmex : Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
        Depends: libwxgtk-webview3.0-0 (>= 3.0.2) but it is not installable
        Depends: libwxgtk3.0-0 (>= 3.0.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I guess this issue will recur for even the LTS release coming soon. Any plans to support 15.10 and above?
Re: Finally a PPA for Ubuntu!

dwrj87
New MMEX User

Posts: 3
Joined: Fri Mar 18, 2016 1:28 pm
vinu wrote:Thanks for providing the ppa. I am trying to install from Ubuntu 15.10 and the above repository is only available for 15.04 and 14.04. When I force my apt to fetch from Vivid (trying my luck :)) and install mmex, I am getting the following error:

The following packages have unmet dependencies:
 mmex : Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
        Depends: libwxgtk-webview3.0-0 (>= 3.0.2) but it is not installable
        Depends: libwxgtk3.0-0 (>= 3.0.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I guess this issue will recur for even the LTS release coming soon. Any plans to support 15.10 and above?
I did have a problem uploading the latest version to the PPA, but it has been fixed. At the moment, 14.04, 15.04, 15.10 and 16.04 are available.
Re: Finally a PPA for Ubuntu!

dwrj87
New MMEX User

Posts: 3
Joined: Fri Mar 18, 2016 1:28 pm
@GabrielleV You can change the latest available version for Unix back to the same for Windows now. I've bought the PPA up to date again, and written a script so I can can update the PPA quite quickly
Re: Finally a PPA for Ubuntu!
User avatar
overkill22
New MMEX User

Posts: 10
Joined: Sun Jun 05, 2016 7:32 pm
Hi guys,
I still have this problem on linux mint 17.3

Code: Select all
The following packages have unmet dependencies.
 mmex : Depends: libwxbase3.0-0v5 (>= 3.0.2+dfsg) but it is not going to be installed
        Depends: libwxgtk-webview3.0-0v5 (>= 3.0.2+dfsg) but it is not going to be installed
        Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
how can I solve?
Who is online

Users browsing this forum: Google [Bot] and 11 guests