Errors Compiling 0.9.5

Page 1 of 1
3 posts
Errors Compiling 0.9.5

madhan
Site Admin

Posts: 242
Joined: Sun Nov 30, 2008 2:06 pm
Is the base build requirements changed?

I usually have a compiled wxWidgets version I use for building. When I downloaded 0.9.5 and compiled, I get a lot of these errors:

Code: Select all
1>c:\wxwidgets-2.8.8\include\wx\msw\registry.h(15) : error C2144: syntax error : 'wxOutputStream' should be preceded by ';'
1>c:\wxwidgets-2.8.8\include\wx\msw\registry.h(15) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>budgetyeardialog.cpp


Which looks like some basic setting/switch is missing. Do I need to regenerate the vcproj files etc?
Re: Errors Compiling 0.9.5

Nikolay
MMEX Developer

Posts: 2284
Joined: Sat Dec 06, 2008 8:27 am
Location: Sankt-Petersburg, Russia
Hi Madhan,

Exclude c:\wxwidgets-2.8.8\include\wx\msw from path or the compiler settings.
$(WXWIN)\lib\vc_lib and $(WXWIN)\lib\msw has been added to
Service - Parameters - Projects - VC++ Catalogues - Libs for my VC++ Express.

Regarsd,
Nick
Re: Errors Compiling 0.9.5

madhan
Site Admin

Posts: 242
Joined: Sun Nov 30, 2008 2:06 pm
I guess something did change, I switched to wxWidgets 2.8.10 and it worked with no issues.
Oh Well.
Page 1 of 1
Who is online

Users browsing this forum: No registered users and 1 guest