Build using Visual Studio 2019

Money Manager Ex Development related posts
(http://github.moneymanagerex.org/)

Moderator: Renato

Post Reply
whall3y
New MMEX User
Posts: 14
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Build using Visual Studio 2019

Post by whall3y »

Anybody using Visual Studio 2019? I see the build instructions only go up to 2017 - https://github.com/moneymanagerex/money ... r/BUILD.md

I've followed the instructions and got as far as this (changing to accommodate 2019)

Code: Select all

cmake -G "Visual Studio 16 2019" -DBUILD_CURL_EXE=OFF -DHTTP_ONLY=ON -DENABLE_MANUAL=OFF -DBUILD_TESTING=OFF -DCURL_STATICLIB=ON -DCMAKE_USE_WINSSL=ON -DCMAKE_INSTALL_PREFIX=c:\libcurl ..
but then get an error. Not sure if the original instructions are missing a step to install Perl or this is 2019 related. Any clues?

Code: Select all

-- Selecting Windows SDK version 10.0.18362.0 to target Windows 10.0.18363.
-- The C compiler identification is MSVC 19.27.29111.0
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.27.29110/bin/Hostx64/x64/cl.exe
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.27.29110/bin/Hostx64/x64/cl.exe - works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
CMake Warning at CMakeLists.txt:50 (message):
  the curl cmake build system is poorly maintained.  Be aware


-- curl version=[7.72.0]
-- Could NOT find Perl (missing: PERL_EXECUTABLE)
-- Looking for pthread.h
-- Looking for pthread.h - not found
-- Found Threads: TRUE
-- Looking for getch in ws2_32;
-- Looking for getch in ws2_32; - found
-- Looking for getch in winmm;ws2_32
-- Looking for getch in winmm;ws2_32 - found
CMake Error at CMakeLists.txt:316 (message):
  The cmake option CMAKE_USE_WINSSL was renamed to CMAKE_USE_SCHANNEL.
whall3y
New MMEX User
Posts: 14
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Re: Build using Visual Studio 2019

Post by whall3y »

OK, installed Perl..... And now all good.

Just a slight issue when running and can’t find DLLs for libcurl or some of WX elements. Manually copied them to run directory and now app can be run.

Will investigate what I’ve done wrong with the DLLs, must be missing a path somewhere.
guanlisheng
MMEX Developer
Posts: 218
Joined: Wed Dec 21, 2011 5:58 am
Are you a spam bot?: No
Location: China
Contact:

Re: Build using Visual Studio 2019

Post by guanlisheng »

were you using wxWidgets 3.1.4? i asked bc we have an initial plan to perform the upgrade.
whall3y
New MMEX User
Posts: 14
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Re: Build using Visual Studio 2019

Post by whall3y »

guanlisheng wrote: Tue Aug 25, 2020 9:16 am were you using wxWidgets 3.1.4? i asked bc we have an initial plan to perform the upgrade.
Yes.

Code: Select all

-- Versions
-- --========--
-- Windows 10.0.18363
-- CMake 3.17.20032601-MSVC_2
-- MSBuild 16.7.0.37604
-- Visual Studio 16.0
-- MSVC 19.27.29111.0
-- Win SDK 10.0.18362.0
-- wxWidgets 3.1.4
-- wxSQLite3 4.6.0
-- Lua 5.3.5
-- curl 7.72.0
-- gettext 0.21]
Image
guanlisheng
MMEX Developer
Posts: 218
Joined: Wed Dec 21, 2011 5:58 am
Are you a spam bot?: No
Location: China
Contact:

Re: Build using Visual Studio 2019

Post by guanlisheng »

this is fantastic and i think you can contribut your idea via the code change.
Nikolay
MMEX Developer
Posts: 1402
Joined: Sat Dec 06, 2008 2:27 pm
Are you a spam bot?: No
Location: Sankt-Petersburg, Russia

Re: Build using Visual Studio 2019

Post by Nikolay »

Post Reply