Solved: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

MMEX4Desktop, incl. Windows, macOS (10.10 or newer), and Most Unix variants using the GTK+ toolkit

Moderator: Renato

Post Reply
PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Solved: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by PMaff »

1.5.6-Beta.1 is working ok but I realized disappearing menus right from the beginning; only found time to write this now.
I also tried the latest
1.5.7-Beta.1 - same issue.

-- MMEX configuration summary
-- ==========================
-- Version : 1.5.7-Beta.1
-- Host system : Linux x86_64
-- Target system : Linux x86_64
-- Build types :
-- Generator : Unix Makefiles
-- Install prefix : /usr/local
-- DB encryption : ON
--
-- Versions
-- --========--
-- Linux 4.15.0-147-generic
-- Ubuntu 18.04 'bionic'
-- CMake 3.10.2
-- GNU Make 4.1
-- ccache 3.4.1
-- GNU 7.5.0
-- wxWidgets 3.1.5
-- wxSQLite3 4.6.0
-- Lua 5.3.3
-- curl 7.58.0
-- gettext 0.19.8.1

:
mmex156menudisappears.gif
mmex156menudisappears.gif (72.93 KiB) Viewed 6878 times

Stable version 1.5.6 fails to compile with:

Code: Select all

[...]
moneymanagerex/src/util.cpp:971:93: error: useless cast to type ‘time_t {aka long int}’ [-Werror=useless-cast]
             wxDateTime date = wxDateTime(static_cast<time_t>(entry["time"].GetInt64() / 1000)).GetDateOnly();
                                                                                             ^
cc1plus: some warnings being treated as errors
src/CMakeFiles/mmex.dir/build.make:1550: recipe for target 'src/CMakeFiles/mmex.dir/util.cpp.o' failed
make[2]: *** [src/CMakeFiles/mmex.dir/util.cpp.o] Error 1
Last edited by PMaff on Sun Mar 13, 2022 5:11 pm, edited 1 time in total.
whall3y
Developer
Posts: 345
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by whall3y »

Thanks. These issues are already recorded in the issues log, and the latest status can be tracked here:
https://github.com/moneymanagerex/money ... ssues/3220
https://github.com/moneymanagerex/money ... ssues/3796
PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by PMaff »

whall3y wrote: Mon Aug 23, 2021 9:45 am Thanks. These issues are already recorded in the issues log, and the latest status can be tracked here:
https://github.com/moneymanagerex/money ... ssues/3220
https://github.com/moneymanagerex/money ... ssues/3796
Thanks for information.
What was the reason that the fix in
https://github.com/moneymanagerex/money ... 9e799eb4d3
was not used?

I tried:

Code: Select all

void mmGUIFrame::OnSelChanged(wxTreeEvent& event)
{
    menuPrintingEnable(false);
    wxTreeItemId selectedItem = event.GetItem();
    if (!selectedItem) return;

    mmTreeItemData* iData = dynamic_cast<mmTreeItemData*>(m_nav_tree_ctrl->GetItemData(selectedItem));
    if (!iData) return;

    selectedItemData_ = iData;

m_nav_tree_ctrl->Update(); /* fix from danielrempel */
 
    activeReport_ = false;
[...]
and this solves the problem:
mmex157withfix.gif
mmex157withfix.gif (95.75 KiB) Viewed 6841 times

Were there other side effects, that I do not see?

I also "backported" the correction for the -Werror=useless-cast
from the 1.5.7 beta to the stable version 1.5.6:

Code: Select all

	  /* error: useless cast to type ‘time_t {aka long int}’
            wxDateTime date = wxDateTime(static_cast<time_t>(entry["time"].GetInt64() / 1000)).GetDateOnly();
	  */
	    wxDateTime date = static_cast<wxDateTime>(entry["time"].GetInt64() / 1000).GetDateOnly();
so that I have a compilable stable version 1.5.6 with no disappearing "Left navigation bar icons".
;)
whall3y
Developer
Posts: 345
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by whall3y »

We have not seen a pull request for https://github.com/moneymanagerex/money ... 9e799eb4d3 that is why it was never included.

Do you want to create a pull request?
PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by PMaff »

whall3y wrote: Tue Aug 24, 2021 12:19 am We have not seen a pull request for https://github.com/moneymanagerex/money ... 9e799eb4d3 that is why it was never included.

Do you want to create a pull request?
I did not check possible regressions.
So if you could do a pull request and the other mmex fellows check then?
whall3y
Developer
Posts: 345
Joined: Fri Aug 21, 2020 5:44 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by whall3y »

PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by PMaff »

Thanks.
cupdrat
New User
Posts: 8
Joined: Sun Nov 07, 2021 4:04 pm
Are you a spam bot?: No

Re: Disappearing menus in 1.5.7-Beta.1 and 1.5.6-Beta.1

Post by cupdrat »

1.4.0-alpha.6 fixes the disappearing tree. I was going to upgrade to 1.5x but the build(1.5x) has errors. Gets to 67% and stops.

[build] [104/154 67% :: 598.973] Building CXX object src/CMakeFiles/mmex.dir/webapp.cpp.o
[build] In file included from ../src/reports/reportbase.h:23,
[build] from ../src/util.h:23,
[build] from ../src/webapp.cpp:24:
[build] ../src/reports/mmDateRange.h:49:5: warning: type qualifiers ignored on function return type [-Wignored-qualifiers]
[build] 49 | const int startDay() const;
[build] | ^~~~~
[build] ../src/reports/mmDateRange.h:168:8: warning: type qualifiers ignored on function return type [-Wignored-qualifiers]
[build] 168 | inline const int mmDateRange::startDay() const { return this ? startDay_ : 1; }
[build] | ^~~~~
[build] ninja: build stopped: subcommand failed.
[build] Build finished with exit code 1



wx/wxprec.h: No such file or directory
‘class wxDisplay’ has no member named ‘GetPPI’
‘class wxDisplay’ has no member named ‘GetPPI’

may try 1.5x build on system that does not have important info; if the 1.4.0-alpha.6 fix is not in 1.5x.

if you want to fix the disappearing tree on the home page frame use 1.4.0-alpha.6
Post Reply