Linux Ubuntu 22.04 (64-bit)

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

Linux Mint 20.3 with current updates.
I have been running 18.04 (Bionic) version ok for some time.
Today when opening MMeX I was invided to update, so I install MMeX 22.04 (64-bit) (Jammy) and when I click the MMeX button nothing happens. No warning or error code.
Now I find that Mint 20.3 uses Ubuntu 20.04, so I downloaded the 1.5.16-1 (focal) and ran the deb file.
Asks to install additional file wx3.1-i18n = 3.1.1-1.artful
I get: The installation or removal of a software package failed.
Can someone explain what has happened here?
spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

I uninstalled Mint MATE, wiped the hard drive and re-installed, and updated. It uses Ubuntu Focal.
Downloaded and ran the installation file mmex-1.5.16-1.focal_amd64.deb

Error: Dependency is not satisfiable: wx3.1-i18n

GDebi should automatically install all dependencies. I have the latest GDebi (0.9.5.7xmint10).
User avatar
xdodo49
Super MMEX User
Posts: 22
Joined: Sat May 21, 2016 6:55 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by xdodo49 »

Anche a me succede la stessa cosa . Aspetto che qualcuno ci dia delle indicazioni.
PMaff
Super MMEX User
Posts: 59
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by PMaff »

spaarks wrote: Fri Jul 01, 2022 10:30 am I uninstalled Mint MATE, wiped the hard drive and re-installed, and updated. It uses Ubuntu Focal.
Downloaded and ran the installation file mmex-1.5.16-1.focal_amd64.deb

Error: Dependency is not satisfiable: wx3.1-i18n

GDebi should automatically install all dependencies. I have the latest GDebi (0.9.5.7xmint10).
Did you see:
https://github.com/moneymanagerex/money ... 1106597921
?

Also I assume, that the Ubuntu deb files will not fully work on Mint MATE, since probably Mint has some other library versions than
Ubuntu.
See e.g.: https://github.com/moneymanagerex/money ... 1166307566
Perhaps I find some time to set up a virtual machine with Mint on the weekend and then compile for Mint.
spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

PMaff,
thank you, i ltried the solution in your post of 24Apr.
At line sudo apt-get install wx3.1-i18n I get error:

E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 14463 (apt)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

I don't know Linux code, so don't understand what this means.

I previously (a few weeks ago) installed mmEx on this computer without any problems.
I had to reinstall LM 20, and then got this problem with mmEx.
https://github.com/moneymanagerex/money ... _amd64.deb
PMaff
Super MMEX User
Posts: 59
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by PMaff »

spaarks wrote: Sat Jul 02, 2022 7:17 pm PMaff,
thank you, i ltried the solution in your post of 24Apr.
At line sudo apt-get install wx3.1-i18n I get error:

E: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 14463 (apt)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

I don't know Linux code, so don't understand what this means.
This is something which has nothing to do with mmex.
On Ubuntu most of the time this means you have or had "Software updater" or "Synaptic Package Manager"
or similar running, when try to use apt-get .
Try the following:

Code: Select all

ps aux | grep 14463
to see which process is creating that lock.
Explanation: 'ps' lists all the running processes,
"aux" are some parameters for ps,
'|' is the standard pipe to redirect the output of "ps" to some command after the pipe,
"grep" searches in the output of ps in this case.

Normally if you reboot the system this should go away, but maybe you interrupted some
ongoing download and therefore the lock from process 14463 was left over.
spaarks wrote: Sat Jul 02, 2022 7:17 pm I previously (a few weeks ago) installed mmEx on this computer without any problems.
I had to reinstall LM 20, and then got this problem with mmEx.
https://github.com/moneymanagerex/money ... _amd64.deb
Normally you do not have to reinstall the complete operating system to get a program running.
Also this is quite an effort unless you run in a virtual machine.
spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

denis@denis-23-q130na:~$ ps aux | grep 14463
root 14463 0.0 0.9 89168 75896 ? S Jul01 0:41 /usr/bin/apt install ttf-mscorefonts-installer
denis 43637 0.0 0.0 9036 720 pts/6 S+ 11:03 0:00 grep --color=auto 14463

I did try to install mscorefonts-installer, and it failed. Could this be the problem?
PMaff
Super MMEX User
Posts: 59
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by PMaff »

spaarks wrote: Sun Jul 03, 2022 10:05 am denis@denis-23-q130na:~$ ps aux | grep 14463
root 14463 0.0 0.9 89168 75896 ? S Jul01 0:41 /usr/bin/apt install ttf-mscorefonts-installer
denis 43637 0.0 0.0 9036 720 pts/6 S+ 11:03 0:00 grep --color=auto 14463

I did try to install mscorefonts-installer, and it failed. Could this be the problem?
So this process seems to be still running.
The question is: what made it fail or what interrupted it so that the lock file is still there?

Did you try

Code: Select all

sudo apt-get -f --reinstall ttf-mscorefonts-installer
?
There are others with similar problems:
https://askubuntu.com/questions/829247/ ... -installer

I guess you also read this one:
https://linuxhint.com/ttf-mscorefonts-installer/

Btw. I never needed Microsoft’s Truetype fonts. ;)
spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

$ sudo apt-get -f --reinstall ttf-mscorefonts-installer
[sudo] password for denis:
E: Command line option 'f' [from -f] is not understood in combination with the other options.

The mscorefonts is not important to me. How can I uninstall it?
spaarks
New MMEX User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

I uninstalled it, I think :
sudo rm -rf /usr/share/fonts/truetype/msttcorefonts

Did not return any message.

Cleared cache.
mmEx deb installer gives same error.
Post Reply