mmex v1.5.19 (2022.08.19 non funziona

Almost any Unix workstation with GTK+ 2.0 and above.

Moderator: Renato

PMaff
Super MMEX User
Posts: 69
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: mmex v1.5.19 (2022.08.19 non funziona

Post by PMaff »

Ok Fedora.
As far as I can see we only have Fedora versions lately and 2 older ones here:
https://moneymanagerex.org/docs/downloads/older/
Do the older versions also fail?

How much memory do you have on that machines?
Most of the time 'std :: bad_alloc' shows, that some memory cannot be allocated
either some problems with memory and swap or some defect memory.
You are right, it is strange that this only comes up with mmex, so we now try to
"load test" the memory of your computers without installing mmex:

What happens if you open -say- 10 windows with 20 tabs each in firefox with different content on these machines
or if you load large Word files into libreoffice?
Also quite a nice test:
load that image with firefox:
https://www.heise.de/downloads/18/3/5/9 ... 220804.png
[ https://www.heise.de/news/Viele-Galaxie ... .mail.link ]
save it and load it with gimp.
This already takes long in firefox on my machine with 16GB and quite a good processor,
it probably will freeze your older machines, so save old work before testing!
PMaff
Super MMEX User
Posts: 69
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: mmex v1.5.19 (2022.08.19 non funziona

Post by PMaff »

I compiled the 1.5.20 on my Jammy-Virtual machine with wxWidget 3.2.0:

Code: Select all

Money Manager Ex
Version: 1.5.20 64-bit
• Build on Sep 11 2022 14:03:58
• Database version: 7 • (aes128cbc)
• Git commit: 3e27ceb7f (2022-09-02)
MMEX is using the following support products:
• wxWidgets 3.2.0 (wxGTK 3.24)
• wxSQLite3 4.6.0 (SQLite 3.31.1)
• RapidJSON 1.1.0
• Lua 5.3.6
• lunasvg v2.3.1
• libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13
• gettext 0.21
• apexcharts.js
Build using:
• CMake 3.22.1
• GNU Make 4.3
• GCC 11.2.0 • Ubuntu.22.04.jammy
Running on:
• Ubuntu 22.04.1 LTS "jammy"
• Linux 5.15.0-47-generic x86_64
• GNOME English (United States) (UTF-8)
• 0x0 0bit 96x96ppi
under X11 (not Wayland!) and it works ok.

Also I tried the version from https://moneymanagerex.org/docs/downloads/latest/ with "About":

Code: Select all

Money Manager Ex
Version: 1.5.20 64-bit
• Build on Sep 2 2022 13:14:17
• Database version: 7 • (aes128cbc)
MMEX is using the following support products:
• wxWidgets 3.1.7 (wxGTK 3.24)
• wxSQLite3 4.6.0 (SQLite 3.31.1)
• RapidJSON 1.1.0
• Lua 5.3.6
• lunasvg v2.3.1
• libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13
• gettext 0.21
• apexcharts.js
Build using:
• CMake 3.22.1
• GNU Make 4.3
• GCC 11.2.0 • Ubuntu.22.04.jammy
Running on:
• Ubuntu 22.04.1 LTS "jammy"
• Linux 5.15.0-47-generic x86_64
• (UTF-8)
• 0x0 0bit 96x96ppi
which also runs ok on the X11 Jammy.

Question is if it is a Wayland issue again.
So you can try:
echo $XDG_SESSION_TYPE
which gives "x11" on a non-Wayland system.
Post Reply