Linux Ubuntu 22.04 (64-bit)

MMEX4Desktop, incl. Windows, macOS (10.10 or newer), and Most Unix variants using the GTK+ toolkit

Moderator: Renato

Post Reply
PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by PMaff »

spaarks wrote: Sun Jul 03, 2022 6:33 pm $ sudo apt-get -f --reinstall ttf-mscorefonts-installer
[sudo] password for denis:
E: Command line option 'f' [from -f] is not understood in combination with the other options.

The mscorefonts is not important to me. How can I uninstall it?
Before uninstalling you should check, if anything is broken in your package system.

I try to put the other post also here:
spaarks wrote: Sun Jul 03, 2022 8:04 pm I uninstalled it, I think :
sudo rm -rf /usr/share/fonts/truetype/msttcorefonts

Did not return any message.

Cleared cache.
mmEx deb installer gives same error.
No, actually you removed it only from the directory and your package system might still think that it is there.
This might complicate the situation.
:(
Installation of mmex will probably fail because the package system has still some error.

Try

Code: Select all

sudo apt-get purge ttf-mscorefonts-installer
Hopefully your simple deletion in the directory does not interfere here.
Last edited by PMaff on Fri Jul 08, 2022 4:40 pm, edited 2 times in total.
spaarks
New User
Posts: 17
Joined: Sat Jan 14, 2012 11:40 am
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by spaarks »

Sorry, mscorefonts was nothinng to do with the problem with mmex.
No matter what version of mmex I try gives Error: Dependency is not satisfiable: wx3.1-i18n
I can't get mmex to run on WINE.
PMaff
Super User
Posts: 74
Joined: Sun Aug 11, 2019 1:57 pm
Are you a spam bot?: No

Re: Linux Ubuntu 22.04 (64-bit)

Post by PMaff »

spaarks wrote: Mon Jul 18, 2022 1:34 pm Sorry, mscorefonts was nothinng to do with the problem with mmex.
No matter what version of mmex I try gives Error: Dependency is not satisfiable: wx3.1-i18n
I can't get mmex to run on WINE.
The wx3.1-i18n is solved for wxWidget 3.1.* and mmex <= 1.5.16.
See:
https://github.com/moneymanagerex/money ... 1106597921

The problem for Ubuntu 22.04 is, that the *.deb was created by me for X11 and not for Wayland.
As soon as I have time for this I will take a look at it.
But if you compile wxWidget 3.1.5 from source and then mmex 1.5.16 from source the above tip for
wx3.1-i18n should help.

For wxWidget 3.2 and mmex > 1.5.16 there is an ongoing issue:
https://github.com/moneymanagerex/money ... 1190800256
Post Reply